Elevated latency
Incident Report for Height
Resolved
This incident has been identified and resolved. Height is now back up and fully operational.
Posted Feb 05, 2024 - 17:17 UTC
Investigating
Some people are unable to load Height. We're investigating and will post an update soon.
Posted Feb 05, 2024 - 17:04 UTC
This incident affected: Height.