Some users are having issues loading Inbox

Incident Report for Height

Resolved

This incident has been resolved and Height is fully functional again. Our sincere apologies for the disruption!
Posted Nov 03, 2022 - 16:55 UTC

Update

We're deploying a fix and will monitor the results.
Posted Nov 03, 2022 - 15:41 UTC

Identified

We've identified the root cause of the issue and are currently working on a fix.
Posted Nov 03, 2022 - 14:23 UTC

Investigating

Some people are unable to load their Inbox. We're investigating and will post an update soon.
Posted Nov 03, 2022 - 14:18 UTC
This incident affected: Height.