Service latency
Incident Report for Height
Resolved
We've identified the root issue and deployed a fix. All delayed notifications, emails, and integration actions should be received / completed. Sorry for the disruption!
Posted May 31, 2022 - 21:17 UTC
Investigating
Some users are experiencing significantly delay in their notifications, emails, and integration actions. We're investigating and will keep you posted.
Posted May 31, 2022 - 20:54 UTC
This incident affected: Height.