Degraded performance

Incident Report for Height

Resolved

This incident has been resolved.
Posted Nov 18, 2022 - 12:59 UTC

Update

We are continuing to investigate this issue.
Posted Nov 18, 2022 - 12:58 UTC

Investigating

Start of degraded performance when opening tasks
Posted Nov 17, 2022 - 13:00 UTC
This incident affected: Height.